Welcome to the Sophos User Bulletin Board.
If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Reply
 
LinkBack Thread Tools Display Modes
Member
Join Date: Nov 2011
Posts: 30
#1 (permalink)  
Old 07-18-2012, 11:59 AM
Default SMTP Proxy connection refused

Hi @ All

i have installed the UTM 9 Release (9.000-8) and enabled the SMTP Proxy. But i cant connect from the Internet or the local network:

Code:
connection refused
anybody an idea?
thanks

Last edited by hacker; 07-23-2012 at 03:34 PM.
Reply With Quote
Member
Join Date: Nov 2011
Posts: 30
#2 (permalink)  
Old 07-18-2012, 07:22 PM
Default

hm anybody here?
Reply With Quote
BrucekConvergent's Avatar
Master of Reality
Join Date: Oct 2005
Location: SC, USA
Posts: 4,847
#3 (permalink)  
Old 07-18-2012, 08:30 PM
Default

You're in the wrong forum... let me move you
__________________
Convergent Information Security Solutions, LLC
Sophos Platinum Solution Partner
Reply With Quote
Member
Join Date: Nov 2011
Posts: 30
#4 (permalink)  
Old 07-22-2012, 09:54 AM
Default

the problems only at utm9
i have installed und configured asg8, save a backup file and recovered in utm9, but still the same problem: connection refused on port 25
Reply With Quote
Senior Member
Join Date: Jun 2009
Posts: 157
#5 (permalink)  
Old 07-23-2012, 10:27 AM
Default

Quote:
Originally Posted by hacker View Post
the problems only at utm9
i have installed und configured asg8, save a backup file and recovered in utm9, but still the same problem: connection refused on port 25
Hi,
ever tried to disable the 'Adbdvanced anti-spam features' like (reject invalid help messages, BATV, SPF, Greylisting)?
Checked already packetfilter.log?

Cheers,
ciscoman
Reply With Quote
Member
Join Date: Nov 2011
Posts: 30
#6 (permalink)  
Old 07-23-2012, 03:01 PM
Default

the file display following:
/var/chroot-smtp/tmp/smtpd_debug.log

Code:
1 Carp::carp
2 DBI::__ANON__
3 DBI::connect
4 modules::sql::sql_connect
MASTER[21887] WARN at Tue Jul 24 08:52:49 2012 -------------------------------------------------------
Unable to connect to database, retrying in 10 seconds.
1 modules::sql::sql_connect
2 modules::sql::sql_tables
MASTER[21887] WARN at Tue Jul 24 08:52:59 2012 -------------------------------------------------------
DBI connect('dbname=smtp;host=db_host.local;port=5432;','postgres',...) failed: FATAL:  database "smtp" does not exist at /</bin/smtpd.bin>modules/sql.pm line 42
1 Carp::carp
2 DBI::__ANON__
3 DBI::connect
4 modules::sql::sql_connect
MASTER[21887] WARN at Tue Jul 24 08:52:59 2012 -------------------------------------------------------
Unable to connect to database, retrying in 10 seconds.
1 modules::sql::sql_connect
2 modules::sql::sql_tables
s

Last edited by hacker; 07-24-2012 at 06:53 AM.
Reply With Quote
Billybob's Avatar
Wizard
Join Date: Jul 2006
Location: United States
Posts: 1,818
#7 (permalink)  
Old 07-24-2012, 02:14 PM
Default

Quote:
FATAL: database "smtp" does not exist at /</bin/smtpd.bin>modules/sql.pm line 42
Seems your database is broken. Without a functioning database, the smtp proxy doesn't work. Try rebuilding the database or better yet, reinstall and import your backup.
Reply With Quote
Member
Join Date: Nov 2011
Posts: 30
#8 (permalink)  
Old 07-24-2012, 03:02 PM
Default

thanks for your answer

how can i rebuild the database?
I've tried some new installations, unfortunately, remains at the utm starting postgresql depend.
Reply With Quote
Billybob's Avatar
Wizard
Join Date: Jul 2006
Location: United States
Posts: 1,818
#9 (permalink)  
Old 07-24-2012, 07:34 PM
Default

I always rebuild after database corruption but you can try the following
Code:
/var/mdw/scripts/smtp stop
dropdb -U postgres smtp
su - postgres /var/storage/pgsql/init/smtp.sh
/var/mdw/scripts/smtp start
and look for any error messages.

Edit: Here is an article I found explaining the above How to reset the SMTP database for Astaro security gateway - Knowledgebase - Support - Sophos
Reply With Quote
Member
Join Date: Nov 2011
Posts: 30
#10 (permalink)  
Old 07-25-2012, 06:00 AM
Default

it works perfekt thank you very much.
Code:
utm:/root # /var/mdw/scripts/smtp stop
:: Stopping SMTP Proxy
[ ok ]
utm:/root # dropdb -U postgres smtp
dropdb: database removal failed: ERROR:  database "smtp" does not exist
utm:/root # createdb -U postgres smtp
utm:/root # /var/mdw/scripts/smtp start
:: Starting SMTP Proxy
[ ok ]
thread can be closed
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 07:06 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.

These pages are specifically maintained for the discussion of firewall issues within the Open Source community, and might already reflect new alpha/beta releases under development. Please refer to our product specifications for the functionality of the actual release. Discussions of new/enhanced functionality does not constitute a commitment of Astaro, to integrate this functionality into future releases.