Welcome to the Sophos User Bulletin Board.
If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Reply
 
LinkBack Thread Tools Display Modes
Junior Member
Join Date: May 2004
Posts: 4
#1 (permalink)  
Old 05-25-2004, 08:14 PM
Default GRE: Bad checksum from pppd

When I try to connect to PPTP using Windows XP as a client the authentication fails and I see the following error in the Astaro logs:

2004:05:25-13:00:31 (none) pppd-pptp[3303]: Starting negotiation on /dev/ttyp0
2004:05:25-13:00:31 (none) pppd-pptp[3303]: sent [LCP ConfReq id=0x1 <mru 1490> <asyncmap 0x0> <auth chap MS-v2> <magic 0xcd2d30cc> <pcomp> <accomp> <mrru 1490> <endpoint [MAC:00:50:8b:c8:61:94]>]
2004:05:25-13:00:31 (none) pptpd[3302]: GRE: Bad checksum from pppd.

Please - let me know if you have any idea what the problem might be.

Thanks
Reply With Quote
Member
Join Date: Oct 2002
Location: Auckland
Posts: 32
#2 (permalink)  
Old 05-27-2004, 07:58 AM
Default Re: GRE: Bad checksum from pppd

Same here the exact same problem. ASl V 5.009. I have checked my config, and I thought it was my setup.

2004:05:27-14:12:36 (none) pppd-pptp[12188]: AUA plugin initialized.
2004:05:27-14:12:36 (none) pppd-pptp[12188]: Plugin /usr/sbin/aua.so loaded.
2004:05:27-14:12:36 (none) pppd-pptp[12188]: AUA plugin initialized.
2004:05:27-14:12:36 (none) pppd-pptp[12188]: pppd 2.4.2 started by (unknown), uid 0
2004:05:27-14:12:36 (none) pppd-pptp[12188]: Starting negotiation on /dev/ttyp0
2004:05:27-14:12:36 (none) pptpd[12185]: GRE: Bad checksum from pppd.
2004:05:27-14:12:49 (none) pppd-pptp[12188]: Terminating on signal 2.
2004:05:27-14:12:49 (none) pppd-pptp[12188]: Modem hangup

Also I cannot VPN from my Lan PC to any external sites.

Anyone ideas?
Have checked
-Packet Filter Rules
-User Settings i.e allow PPTP
-User password
-PPTP enabled Authentication local users.
-NAT

However I can PPTP to the Internal interface of my astaro.
This proves it is not a username/pwd issue.

ahhh can't see what is wrong.
Reply With Quote
Junior Member
Join Date: May 2004
Posts: 4
#3 (permalink)  
Old 05-27-2004, 04:02 PM
Default Re: GRE: Bad checksum from pppd

I had it work for me. What happens is that I am getting this error when I try to connect to the VPN coming from the same private LAN. When I connect to the VPN from a different network it worked just fine.
Reply With Quote
Member
Join Date: Oct 2002
Location: Auckland
Posts: 32
#4 (permalink)  
Old 05-28-2004, 05:22 AM
Default Re: GRE: Bad checksum from pppd

Weird , I have got it all working and this is what I did.
-Turn off PPTP VPN Server in Astaro
-Restart Astaro
-Test PPTP vpn to remote site. Works Ok.
-Turn on PPTP VPN Server.
-Restart Astaro.
-Test PPTP vpn to remote site. Working.

Still got to test incoming PPTP connections. Will do this weekend.

Also I had the exact same problem on the New Astaro I had at work. Did the same steps and it fixed that one also.

It seems that from a fresh install of 5.005,plus all updates to 5.009, if your turn on PPTP VPN server first before you PPTP to any remote sites it won't work. If you didn't turn on PPTP VPN server from fresh install and did one VPN to a remote site, then you will have no trouble.

Puzzled. Going to do a fresh install again this weekend to see if that is the case. [img]/images/graemlins/confused.gif[/img]
Reply With Quote
Member
Join Date: Mar 2004
Posts: 38
#5 (permalink)  
Old 06-01-2004, 12:40 PM
Default Re: GRE: Bad checksum from pppd

-push-

same problem here.
Reply With Quote
Junior Member
Join Date: Jun 2004
Posts: 7
#6 (permalink)  
Old 06-04-2004, 12:30 PM
Default Re: GRE: Bad checksum from pppd

I had the same problem. The Cisco VPN client caused the problem. After removing the Cisco client it works.
Reply With Quote
Junior Member
Join Date: Dec 2002
Posts: 12
#7 (permalink)  
Old 06-10-2004, 02:58 PM
Default Re: GRE: Bad checksum from pppd

Working PPTP for two months now fails as well. I have the save checksum error Is this an update specific issue?


2004:06:10-09:49:04 (none) pptpd[32395]: MGR: Manager process started
2004:06:10-09:49:04 (none) pptpd[32395]: MGR: Maximum of 253 connections available
2004:06:10-09:50:00 (none) pptpd[32448]: MGR: Manager process started
2004:06:10-09:50:00 (none) pptpd[32448]: MGR: Maximum of 253 connections available
2004:06:10-09:50:13 (none) pptpd[32505]: CTRL: Client 204.181.204.36 control connection started
2004:06:10-09:50:13 (none) pptpd[32505]: CTRL: Starting call (launching pppd, opening GRE)
2004:06:10-09:50:13 (none) pppd-pptp[32510]: Plugin /usr/sbin/aua.so loaded.
2004:06:10-09:50:13 (none) pppd-pptp[32510]: AUA plugin initialized.
2004:06:10-09:50:13 (none) pppd-pptp[32510]: Plugin /usr/sbin/aua.so loaded.
2004:06:10-09:50:13 (none) pppd-pptp[32510]: AUA plugin initialized.
2004:06:10-09:50:13 (none) pppd-pptp[32510]: pppd 2.4.2 started by (unknown), uid 0
2004:06:10-09:50:13 (none) pppd-pptp[32510]: Starting negotiation on /dev/ttyp0
2004:06:10-09:50:13 (none) pptpd[32505]: GRE: Bad checksum from pppd.
2004:06:10-09:50:43 (none) pppd-pptp[32510]: LCP: timeout sending Config-Requests
2004:06:10-09:50:43 (none) pppd-pptp[32510]: Connection terminated.
2004:06:10-09:50:43 (none) pppd-pptp[32510]: Exit.
2004:06:10-09:50:43 (none) pptpd[32505]: GRE: read(fd=5,buffer=804e7a0,len=8196) from PTY failed: status = -1 error = Input/output error
2004:06:10-09:50:43 (none) pptpd[32505]: CTRL: PTY read or GRE write failed (pty,gre)=(5,6)
2004:06:10-09:50:43 (none) pptpd[32505]: CTRL: Closing child BCrelay with pid 0
2004:06:10-09:50:43 (none) pptpd[32505]: CTRL: Closing child ppp with pid 32510
2004:06:10-09:50:43 (none) pptpd[32505]: CTRL: Client 204.181.204.36 control connection finished

A
Reply With Quote
Junior Member
Join Date: Dec 2002
Posts: 12
#8 (permalink)  
Old 06-15-2004, 02:44 PM
Default Re: GRE: Bad checksum from pppd

Did this thread get ignored or something? I have a satalite location unable to authenticate still. Can the devs please take a look at this?

A
Reply With Quote
druide's Avatar
Member
Join Date: Jan 2004
Posts: 42
#9 (permalink)  
Old 06-23-2004, 02:10 PM
Default Re: GRE: Bad checksum from pppd

same problem :-(
Reply With Quote
Junior Member
Join Date: Jun 2003
Posts: 10
#10 (permalink)  
Old 06-24-2004, 06:58 AM
Default Re: GRE: Bad checksum from pppd

Ah so similar error.

Worked fine before updating to V5 and importing settings from backup. then that same error.

2004:06:23-02:14:21 (none) pptpd[17024]: CTRL: Client ***.***.***.*** control connection started
2004:06:23-02:14:21 (none) pptpd[17024]: CTRL: Starting call (launching pppd, opening GRE)
2004:06:23-02:14:21 (none) pppd-pptp[17025]: Plugin /usr/sbin/radius.so loaded.
2004:06:23-02:14:21 (none) pppd-pptp[17025]: RADIUS plugin initialized.
2004:06:23-02:14:21 (none) pppd-pptp[17025]: Plugin /usr/sbin/radattr.so loaded.
2004:06:23-02:14:21 (none) pppd-pptp[17025]: RADATTR plugin initialized.
2004:06:23-02:14:21 (none) pppd-pptp[17025]: Plugin /usr/sbin/radius.so loaded.
2004:06:23-02:14:21 (none) pppd-pptp[17025]: RADIUS plugin initialized.
2004:06:23-02:14:21 (none) pppd-pptp[17025]: Plugin /usr/sbin/radattr.so loaded.
2004:06:23-02:14:21 (none) pppd-pptp[17025]: RADATTR plugin initialized.
2004:06:23-02:14:21 (none) pppd-pptp[17025]: pppd 2.4.2 started by (unknown), uid 0
2004:06:23-02:14:21 (none) pppd-pptp[17025]: Starting negotiation on /dev/ttyp0
2004:06:23-02:14:21 (none) pptpd[17024]: GRE: Bad checksum from pppd.
2004:06:23-02:14:22 (none) pptpd[17024]: CTRL: Ignored a SET LINK INFO packet with real ACCMs!
2004:06:23-02:14:22 (none) pppd-pptp[17025]: rc_map2id: can't find tty /dev/ in map database
2004:06:23-02:14:22 (none) pppd-pptp[17025]: Using interface ppp0
2004:06:23-02:14:22 (none) pppd-pptp[17025]: MPPE required, but keys are not available. Possible plugin problem?
2004:06:23-02:14:22 (none) pppd-pptp[17025]: Connection terminated.
2004:06:23-02:14:22 (none) pppd-pptp[17025]: Connect time 0.1 minutes.
2004:06:23-02:14:22 (none) pppd-pptp[17025]: Sent 0 bytes, received 0 bytes.
2004:06:23-02:14:22 (none) pppd-pptp[17025]: Exit.
2004:06:23-02:14:22 (none) pptpd[17024]: GRE: read(fd=5,buffer=804e7a0,len=8196) from PTY failed: status = -1 error = Input/output error
2004:06:23-02:14:22 (none) pptpd[17024]: CTRL: PTY read or GRE write failed (pty,gre)=(5,6)
2004:06:23-02:14:22 (none) pptpd[17024]: CTRL: Closing child BCrelay with pid 0
2004:06:23-02:14:22 (none) pptpd[17024]: CTRL: Closing child ppp with pid 17025
2004:06:23-02:14:22 (none) pptpd[17024]: CTRL: Client ***.***.***.*** control connection finished

When comparing settings to working, after update imported settings in another FW cant see any differences, this another one just works.

Anyone any ideas what to do next ?
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 09:58 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.

These pages are specifically maintained for the discussion of firewall issues within the Open Source community, and might already reflect new alpha/beta releases under development. Please refer to our product specifications for the functionality of the actual release. Discussions of new/enhanced functionality does not constitute a commitment of Astaro, to integrate this functionality into future releases.