Welcome to the Sophos User Bulletin Board.
If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Reply
 
LinkBack Thread Tools Display Modes
Junior Member
Join Date: Feb 2008
Posts: 14
#1 (permalink)  
Old 02-04-2008, 02:46 PM
Default SMTP Eingehende Mails gehen verloren

Ah, ich hab das dt. Forum zu spät entdeckt.

Habe bereits im engl. Bereich (mehr schlecht als recht mit meinem Englisch) gepostet und hoffe ich kriege nun keine Prügel für das doppelt posten.
Bei uns brennt es sehr gerade.

Einkommende Mails gehen bei uns auf der Astaro verloren (Model ASG 120 and firmware 7.101).

Ich kriege zig mails vom ISP zu uns auf die Astaro geleitet.
Diese empfängt diese auch brav, leitet dann aber mit Unterbrechungen nur teilweise die Mails weiter.
Es scheint so, als wollle sie ständig die Mails zum Mailserver durchstellen (so zeigt es auch das maillogfile) aber aus irgendwelchen Gründen klappt es nur alle paar Minuten für einen Schub Mails, bevor dann minutenlang wieder gar nix passiert.


Manchmal bekomme ich eine mail mit 2 Tagen Verspätung bei der ich im Mailheader dann sehe, dass sie auf Astaro lag.

Wenn ich unter SMTP unter Quarantäne gucke habe ich z.B. unter SMTP und auch unter unaffected eine Zahl von 10.000 wobei keine einzige auf Zustellung wartend steht.
Dann kommen Mails und viel SPAM herein und in Quarantäne stehen dann 11.300 Mails . WIeder steht keine auf Zustellung wartend.

Dann geht plötzlich etwas voran und ich bekommen dann doch vielleicht 300 zum Mailserver zugestellt.

In Quarantäne stehen danach nur noch jeweils bei SMTP und unaffected 11.000.

Diese Zahlen gehen nach Zustellung also wieder herunter. Insgesamt bleibt aber immer ein delta zwischen EIngang und Zustellung daher wächst die Zahl hier weiter und mittlerweile vermissen wir wirklich sehr viele Mails und nicht nur SPAM.

Mein Log ist auf der Astaro ist durch die vielen Fehler sehr groß und sich habe viele EInträge wie
2008:02:04-00:02:28 (none) exim[22475]: 2008-02-04 00:02:28 1JL6a0-0006Jo-Ot == johann.mueller AT beispieldomain.de R=static_route_hostlist T=static_smtp defer (-53): retry time not reached for any host

SPAM oder Antiviren Funktionalitäten sind auf der Astaro nicht aktiviert.

Eins noch. Wir bekommen sehr viele SPAM Mails mit ungültigen Adressdatern bei uns aber auch ungültigen Absenderdaten (tausende pro Tag) .
Ich weiss nicht ob das eine Rolle spielt bei dem Problem.

Der Knackpunkt scheint mir, dass aus irgendwelchen Gründen die neue Astaro die Mails nicht permanent zustellen kann an den Mailserver und die Mails dann auf der Astaro liegen bleiben.

Bevor wir die Astaro haten, kannten wir keine Mailprobleme.

Zum einen würde ich die hoffentlich auf der Astaro noch vorhandenen Mails nun mal runter bekommen , zum anderen hätte ich natürlich gerne eine Lösung des Problems.
Der Mailserver selbst ist permanent ansprechbar auch an Port 25 und zeigt keinerlei Probleme. Ich gehe daherr davon aus, dass es nicht am Mailsever liegt



Jede Hilfe ist sehr willkommen. Gruß Alex
Reply With Quote
KKnecht's Avatar
Wizard
Join Date: Mar 2001
Location: Karlsruhe, Germany
Posts: 778
#2 (permalink)  
Old 02-04-2008, 03:11 PM
Default

Hallo Alex,

wenn ich es richtig verstanden habe, liegen auf Deiner ASG120 ca. 10.000 Mails in Quarantäne ? Das ist zuviel für das System.

Aber zum Verständnis: SPAM- und Mail-Filtering sind beide aus ??
Wie ist denn Dein SMTP Proxy auf der Astaro konfiguriert ?

Die Firewall versucht jede Mail die für Eure Domäne ankommt auch zuzustellen.
Wenn der Empfänger nicht bekannt ist, wird versucht den (i.d.R. ebenfalls gefälschte) Absender darüber zu informieren. Wenn Ihr also nicht mal "Verify Recipient" aktiviert habt, prozessiert die Firewall unnötig tausende Mails am Tag, anstatt sie gleich abzulehnen.
D.h. Eure Firewall ist nur noch damit beschäftigt "Müll" umherzuwälzen und bleibt daher fast stehen. Ihr solltet dringend ein paar Anti-SPAM Features aktivieren.

Wenn Du mehr über Deine Konfiguration schreibst, können wir sicher beim optimieren helfen.
__________________
Astaro addict since v1.6
ASGS 9.3xx, MSI H97M-G43, Intel Core i3-4360, 8GB RAM
Reply With Quote
Junior Member
Join Date: Feb 2008
Posts: 14
#3 (permalink)  
Old 02-04-2008, 03:28 PM
Default

Erstmal danke für die rasche Response.

Zu den 10.000.
Ja das denke ich, dass sie das tun (grösstenteils natürlich SPAM).
In der Hilfe steht zwar, dass die Zahlenangaben dort nur statistisch u sehen sind, wieviele Mails bearbeitet wurden, das glaube ich aber nicht.

Wir haben jetzt gerade mal das Kabel zum ISP gekappt damit die Astaro die möglichkeit erhält gespeicherte Mails zuzustellen, ohne dass immer neue Mails dazwischen funken. Mit scheint hier annähernd gehst es bei der Reihefolge um ein last in first out.

SPAM und Mailfiltering sind beides aus auf der Astaro richtig.
Wir lassen beim ISP vortaggen für SPAM und den Virenfilter haben wir aufgrund des Astaroverkäufers abgeschalten weil wir mit regelmässigen Abstürzen zu kämpfen hatten.

Jetzt kenne ich mich leider nicht so gut mit der Maschine aus (Maschine neu und ich eigentlich kein VollAdmin), wo kann ich dieses verify recipent Aktivioerung sehen ? Es ist mir bisher beim durchklicken noch nicht aufgefallen.

Ja, wir bekommen, sehr viele Mails rein die müll sind und im Endeffekt dann nach Zustellung am Mailserver totlaufen und dort gelöscht werden.

Wenn, da nataürlich tausende auf der Astaro hängen bleiben und diese dann versucht etwas zurück zuschreiben wird es problematisch.

Mit welchen Konfigurationsdaten von mir könnte mir geholfen werden ?

Vielen Dank nochmal für die Antwort bisher , Alex
Reply With Quote
Junior Member
Join Date: Feb 2008
Posts: 14
#4 (permalink)  
Old 02-04-2008, 03:49 PM
Default

Nachtrag zu verify recipent: Am Mailserver ist das nicht eingestellt wenn das gemeint war.

Gruß Alex
Reply With Quote
KKnecht's Avatar
Wizard
Join Date: Mar 2001
Location: Karlsruhe, Germany
Posts: 778
#5 (permalink)  
Old 02-04-2008, 04:19 PM
Default

Welchen Mailserver setzt Du ein (Exchange / Lotus etc.) ?

Aus der Hilfe von Astaro:
Quote:
As an additional anti-spam feature, the SMTP proxy tacitly checks each recipient address it receives with your backend mail server(s) before accepting mail for this address. E-mails for invalid recipient addresses will not be accepted. In order for this function to work, your backend mail server(s) must reject mails for unknown recipients at the SMTP stage. The general rule is that if your backend server rejects a message, the SMTP proxy will reject it, too.
Was ist in der Astaro für SPAM eingestellt ? Durchlassen oder in Quarantäne ?
Welche "Tresholds" ?
__________________
Astaro addict since v1.6
ASGS 9.3xx, MSI H97M-G43, Intel Core i3-4360, 8GB RAM
Reply With Quote
Wizard
Join Date: Sep 2001
Location: Munich, GER
Posts: 747
#6 (permalink)  
Old 02-04-2008, 04:24 PM
Default

Quote:
Originally Posted by Cleve View Post
Nachtrag zu verify recipent: Am Mailserver ist das nicht eingestellt wenn das gemeint war.

Gruß Alex
Wenn Du das jetzt aktivierst, dann wird sich Euer ISP freuen, denn dann bleiben bei denen die Mails hängen und verstopfen dort die Systeme.
Reply With Quote
Junior Member
Join Date: Feb 2008
Posts: 14
#7 (permalink)  
Old 02-04-2008, 04:32 PM
Default

Mailserver Domino.

Auf der Astaro bei SPAM ist nix eingestellt (bei Reiter Anti-SPAM alles leer).
Die kommen durch.
Und welche Thresholds meinst Du ?
Vielen Dank, Alex
Reply With Quote
Wizard
Join Date: Sep 2001
Location: Munich, GER
Posts: 747
#8 (permalink)  
Old 02-04-2008, 04:57 PM
Default

Alex,

Deine o.a. Logmeldung sag nur, dass die ASG die Mails an Deinen Mailserver nicht loswerden konnte....
Reply With Quote
Junior Member
Join Date: Feb 2008
Posts: 14
#9 (permalink)  
Old 02-04-2008, 05:11 PM
Default

Quote:
Originally Posted by ClausP View Post
Alex,

Deine o.a. Logmeldung sag nur, dass die ASG die Mails an Deinen Mailserver nicht loswerden konnte....
Hmm danke.
Dachte, man könnte auf Ursachen schliessen.
Die Mengen die wir haben finde ich nicht so dramatisch, als dass die Astaro beim Zustellen schwächeln dürfte.

Mailuser ca. 40.
Mail mit der SPAM Problematik schon hoch.
Daten heute.
890MB Traffic,
Packets blocked by Firewall: 4447
E-Mails processed: 2496

Grüße, Alex
Reply With Quote
Wizard
Join Date: Sep 2001
Location: Munich, GER
Posts: 747
#10 (permalink)  
Old 02-04-2008, 05:22 PM
Default

... anhand des Logs ist das Problem nicht die Astaro, sondern Euer interner Mailserver hat die Mails von der Astaro nicht "abgenommen".

Die Forensuche wird Dir zu diesem Problem Treffer liefern.

Habt Ihr eventuell irgendwelche Begrenzungen auf Eurem internen Mailserver gesetzt ? Oder laufen auf dem Domino noch zusätzliche Prüfungen wie z.B. Sender/Absender überprüfung etc. ?
Habt Ihr eventuell auf dem Server noch einen Virenscanner als SMTP vorgeschaltet ?
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 11:47 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.

These pages are specifically maintained for the discussion of firewall issues within the Open Source community, and might already reflect new alpha/beta releases under development. Please refer to our product specifications for the functionality of the actual release. Discussions of new/enhanced functionality does not constitute a commitment of Astaro, to integrate this functionality into future releases.